Need to link amember and xenforo

Discussion in '3rd Party Service Providers' started by themehunk, Dec 30, 2016.

Thread Status:
Not open for further replies.
  1. themehunk

    themehunk New Member

    Joined:
    Mar 21, 2015
    Messages:
    6
    I need to link my amember with xenforo account. So that my existing users can login to xenforo with amember details. And also same for future users.

    Do let me know the complete process.
  2. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    Hello,

    Happy New Year!

    You can do it with xenforo integration plugin (40$).

    All integration plugins in aMember works the following way:
    • sync user database between aMember and 3ty part script
    • set user group in 3ty part script based on user active subscriptions in aMember
    • implement single login feature between aMember and 3ty part script
    Reference:
    http://www.amember.com/docs/How_It_Works#Integration_Plugins

    Best Regards.
  3. themehunk

    themehunk New Member

    Joined:
    Mar 21, 2015
    Messages:
    6
    Hello,

    Happy new year to you too.

    I tried to purchase that plugin but it is asking me to pay for subscription also. I dont ant any subscription, just want that plugin.

    Could you please do let me know, how i can get just that plugin.

    Best Regards
  4. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    Subscription for updates is required because of latest version of plugin
    can be not compatible with your currently installed version of aMember.

    Do you mind to contact us in helpdesk?
    https://www.amember.com/support

    Best Regards.
  5. themehunk

    themehunk New Member

    Joined:
    Mar 21, 2015
    Messages:
    6
    Hello there,

    I have integrated xenforo with amember using "xenforo XMD-65328-451". But i am getting an issue.

    When i try to login in my support forum(www.themehunk.com/support), it doesn't allow me to login and redirects to same login page.

    And when i login to amember with same details it allows me to login but when i click logout button it gives the follow error message
    Fatal error: Class 'Am_Cookie' not found in /home/themehunk123/public_html/pro-members/application/default/plugins/protect/xenforo/xenforo.php on line 163

    So please do a complete setup for me. I have wasted my 4 days and it is affecting my business. If it doesn't work then i will be in big loss.

    So please help me out with this issue.

    Thank you.
  6. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    The reason of this issue your version of aMember is old and has not class Am_Cookie yet. It is reason why we require active subscription for support to buy new plugins.

    Do you mind to contact us in helpdesk and provide access details for your installation? I will fix this issue.

    Best Regards.
  7. themehunk

    themehunk New Member

    Joined:
    Mar 21, 2015
    Messages:
    6
    Hello there,

    The update about which you are talking was released before our one year subscription expired. So why we have to pay again for that update. Please provide us that update.

    Best Regards.
  8. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    Do you mind to contact us in helpdesk and provide access details for your installation? I will fix this issue.

    Best Regards.
  9. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    I sent details how to fix this issue in your ticket XMD-65328-451

    I hope it resolve this issue.

    Best Regards.
  10. themehunk

    themehunk New Member

    Joined:
    Mar 21, 2015
    Messages:
    6
    Hello Caesar,

    Thank you for that code. Yes the error is gone now.
    But now i am getting new issue. I have integrated xenforo with amember using "xenforo XMD-65328-451". But now amember user not able to auto login to Xenforo forum. It means auto register to xenforo of amember user is not working.
    Please help.

    Best Regards.
  11. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    I am willing to help you but in order to do it I need access to your setup.

    Do you mind to contact us in helpdesk and provide access details for your installation? I will troubleshoot this issue.
    https://www.amember.com/support

    Best Regards.
  12. themehunk

    themehunk New Member

    Joined:
    Mar 21, 2015
    Messages:
    6
    Issue resolved. You guys are great.
    Thank you for your help.
  13. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    You are welcome!
Thread Status:
Not open for further replies.

Share This Page