Internal server error

Discussion in 'Troubleshooting' started by martijn, Feb 19, 2016.

Thread Status:
Not open for further replies.
  1. martijn

    martijn New Member

    Joined:
    Aug 22, 2006
    Messages:
    2
    Hi all,

    I am getting an 'internal server error' at my magicsculpture.com/amember pages since a few days. I checked the folder and it appears incomplete. Which is odd, because I have been running it for the past ten years and upgraded to version 4 in 2014.
    Anyone has any idea what could have happened? Provider software upgrade? If I reinstall amember, will I lose my current user database?

    Best regards,
    Martijn
  2. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    I guess your server upgrade Apache (webserver) to 2.4.18 that have bug in mod_rewrite that resolved in the following commit
    http://svn.apache.org/viewvc?view=revision&revision=1724656

    Here is workaround: edit .htacecss file in root folder of aMember installation and after
    Code:
    RewriteEngine on
    add two new lines
    Code:
    RewriteCond %{ENV:REDIRECT_STATUS} 200
    RewriteRule .* - [L]
    It should resolve this issue.
    martijn likes this.
  3. martijn

    martijn New Member

    Joined:
    Aug 22, 2006
    Messages:
    2
    That worked great! Thanks a lot!

    Best regards,
    Martijn
  4. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    You are welcome! I hope this post will be useful for other user as well.
Thread Status:
Not open for further replies.

Share This Page