WP post protection problem

Discussion in 'aMember Pro v.4' started by jbildy, Jan 24, 2012.

  1. jbildy

    jbildy Member

    Aug 22, 2006
    On 6th Jan I sent an email to support outlining an error with WP plugin.

    The problem is I want NO protected posts to show up on my blog page or in the 'Recent Post' sidebar widget.

    However, when I have selected "hide" the posts from visitors and non-members in Amember4, no non-protected posts shown up on the blog or 'recent post' widget. None at all. I need ordinary posts to be showing.

    Alexander Ivanov replied to my support email...

    I was told "The problem is aMember filter posts based on wordpress query results, so for example if you have 8 posts on the page, and all these posts are protected, aMember will remove them all from results so, wordpress will think that query didn't return any results."

    I was also told... "I will work on this issue on next week and will send fixed plugin files then."

    It's been 3 weeks and I have heard nothing. I sent another email to support 2 days ago but no reply.

    This issue is hurting my business and I need some action on it.

    Can someone please tell me what's happening?
  2. alexander

    alexander Administrator Staff Member

    Jan 8, 2003
    Sorry for such delay. Unfortunately such fix takes more time then I though before, there is a lot of modifications in plugin and obviously such modifications will require more advanced testing.
    I will send updated plugin files on Friday this week.

Share This Page