Wordpress Widget Not Logging In

Discussion in 'Integration' started by nnaann, Jan 8, 2012.

  1. nnaann

    nnaann New Member

    Joined:
    Dec 12, 2011
    Messages:
    8
    I installed the amember widget onto my Wordpress website, allowing people to log in to their accounts there.

    When trying to log in, people are redirected to www.mysite.com/login. An error message comes up saying the page cannot be found. It also means that they weren't logged in. Why is this, can you please explain how to get the widget working properly?
  2. davidm1

    davidm1 aMember User & Partner

    Joined:
    May 16, 2006
    Messages:
    4,435
    Did you accidentally product the main wordpress front page?

    David
  3. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Make sure that Wordpress Dashboard -> amember -> Settings -> amember Root URL is correct.
  4. charlie14

    charlie14 New Member

    Joined:
    Sep 25, 2008
    Messages:
    2
    Having a similar issue here, though I don't see an aMember section of my WordPress back-end. We can log in successfully when using the Membership Academy widget, but once we do so it won't update the widget itself to reflect that we are an active user. Any ideas? I don't want to hijack the thread, but it seemed like a related issue.
  5. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    I guess you have aMember v3 installed?
    Make sure that user is not redirected to different domain name during login process.
    For example if user login from www.domain.com and at some point is redirected to domain.com there will be issues. So make sure you always use the same domain format in both aMember and wordpress.
  6. charlie14

    charlie14 New Member

    Joined:
    Sep 25, 2008
    Messages:
    2
    Ah, yes that looks like the issue. Many thanks!

Share This Page