Wordpress Plugin Broke Dashboard on Install

Discussion in 'Installation' started by betterthangrey, Sep 18, 2012.

  1. betterthangrey

    betterthangrey New Member

    Joined:
    Sep 13, 2012
    Messages:
    1
    I've searched the forums for a similar situation, but as far as I can tell I've found a unique way to break AMember/WordPress integration. Which is a shame, since I had high hopes for this to be an eventual replacement for my other two sites that use MagicMembers (ptui!). AMember support hasn't responded to my request for help either, which is surprising to me; I'd heard such good things about them.

    Anyway, here's what happened: AMember was installed after we'd had a custom theme built for our site. Supposedly we were supposed to take the AMember plugin (amember4) and put it in the plugins directory in wp-content, but once we did that, two things happened: one, the front page of the site now has this code appearing at the top:

    Warning: call_user_func_array() function.call-user-func-array: First argument is expected to be a valid callback, 'widget_wpAmember_init' was given in/home/fiftysha/public_html/wp-includes/plugin.phpon line 403

    Worse, when I try to access my WordPress Dashboard to, say, configure the plugin or deactivate it or something, I just get this:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'widget_wpAmember_init' was given in/home/fiftysha/public_html/wp-includes/plugin.php on line 403

    Warning: Cannot modify header information - headers already sent by (output started at /home/fiftysha/public_html/wp-includes/plugin.php:403) in/home/fiftysha/public_html/wp-includes/pluggable.php on line 881

    Not terribly useful. I've tried using FTP to remove the plugin, no change. I've tried reinstalling the plugin - no change. As I said, I've emailed support, but no answer.

    Anyone familiar with this, or what might be done short of reinstalling everything?






  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    As far as I can see from your support ticket, you have installed different plugin from thrid-party and that error was not related to aMember v4 plugin.
    Just in case someone will have the same situation, I will include link to correct installation instructions:
    http://www.amember.com/docs/Install_the_WordPress_Plugin

Share This Page