Wordpress login problem, please help...

Discussion in 'Integration' started by thachicc2000, Sep 16, 2015.

  1. thachicc2000

    thachicc2000 New Member

    Joined:
    Oct 11, 2012
    Messages:
    12
    Hi,
    I intergrated amember 4.7.0 with wordpress 4.3.1 multisites. User register in amember and user's info also add in wordpress.
    I logged amember, but when I go to wordpress site, user's status is not login. And I can't login from wordpress site.
    My site:
    Amember: http://vietbuild.info/member
    Wordpress: http://vietbuild.info/raovat
    You can check by user: banhbeo, pass: 123456
    Thanks!
  2. thachicc2000

    thachicc2000 New Member

    Joined:
    Oct 11, 2012
    Messages:
    12
    I try difference user name anh password, but it not woking
    Last edited by a moderator: Sep 17, 2015
  3. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
  4. thachicc2000

    thachicc2000 New Member

    Joined:
    Oct 11, 2012
    Messages:
    12
    1. I see root urls in both aMember and Wordpress are use the same domain name.
    Link amember: http://vietbuild.info/member
    Link wordpress: http://vietbuild.info (multisite), sub-site: http://vietbuild.info/raovat
    2. Security keys in aMember's plugin configuration (aMember CP -> Setup -> Wordpress) exactly the same as in wordpress config
    3. I set integration for Wordpress: 4 records for 4 subsites

    but it not working...
  5. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Contact us in helpdesk and provide ftp info, aMembher CP info and wordpress admin login/password I will check what could be wrong.
  6. thachicc2000

    thachicc2000 New Member

    Joined:
    Oct 11, 2012
    Messages:
    12
    When new user register, after checkout, has error:
    Fatal error: Call to undefined function switch_to_blog() in /home/vietbuild/domains/vietbuild.info/public_html/member/application/default/plugins/protect/wordpress/wordpress.php on line 321

    If I uncheck Enable 'Add user to different blogs' in Amember Setup -> Wordpress, that fatal error above not apear, but user's info isn't add to sub site.

Share This Page