WordPress 3.3.1 and aMember Pro v4

Discussion in 'Integration' started by opm2012, Feb 21, 2012.

  1. opm2012

    opm2012 New Member

    Joined:
    Feb 15, 2012
    Messages:
    1
    I recently purchased aMember Pro v4 and I had no trouble getting it installed on my server and activating the WordPress plugin within aMember.

    However, when I went to my WordPress installation I ran into an issue. I was able to activate the plugin, but when I go to save the settings I get a fatal error.

    I am using WordPress 3.3.1.

    Fatal error: Uncaught exception 'Exception' with message 'Please move <b>require 'Lite.php'</b> line to the top of your file. It should be placed before any html code or php output.' in /public_html/amember/library/Am/Lite.php:28 Stack trace: #0 /public_html/amember/library/Am/Lite.php(22): Am_Lite->initPHPSession() #1 /public_html/amember/library/Am/Lite.php(41): Am_Lite->__construct() #2 /public_html/acri/wp-content/plugins/amember4/amember4.php(127): Am_Lite::getInstance() #3 /public_html/acri/wp-content/plugins/amember4/amember4.php(131): am4PluginsManager::getAPI() #4 /public_html/acri/wp-content/plugins/amember4/views/settings.phtml(13): am4PluginsManager::isConfigured() #5 /public_html/acri/wp-content/plugins/amember4/includes/view.php(87): require('/home/candef3/p...') #6 /public_html/acri/wp-content/plugins/amember4/includes/view.php(106): am4View->fetch() #7 /public_html/acri/wp-content/plugins/amemb in /public_html/amember/library/Am/Lite.php on line 28

    Does anyone have any ideas on what would cause this and how to fix it?
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Please contact us in helpdesk or send message to alexander@cgi-central.net with access info, I will check what can be wrong.
  3. spicyniknaks

    spicyniknaks New Member

    Joined:
    Feb 27, 2012
    Messages:
    20
    I am also getting this error and would appreciate if you can post your findings Alexander.
  4. villageboy

    villageboy New Member

    Joined:
    May 30, 2012
    Messages:
    2
    I am getting the same error as well ...
  5. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Make sure that you have latest plugin version. This issue should not happen in latest version.

Share This Page