using API from SSL subdomain

Discussion in 'Integration' started by cleerclouds, Jan 17, 2013.

  1. cleerclouds

    cleerclouds Member

    Joined:
    Nov 30, 2011
    Messages:
    42
    Hello,

    We have the following problem:

    We want to redirect to a SSL Sub Domain (own IP). Which work fine.
    But than we don´t get the UserID over the

    member/library/Am/Lite.php

    Is this not possible? Or we must do it on a other way?

    Many thanks
    Andy
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Andy,
    So you have amember on subdomain and what to use amember's session on main domain?
    If so you may need to change php session settings in php.ini:

    session.cookie_domain = .yourdomain.com
  3. cleerclouds

    cleerclouds Member

    Joined:
    Nov 30, 2011
    Messages:
    42
    Hi Alex,

    No I have amember on the main domain. After login, amember redirect to a SSL subdomain,
    and there I need access to amember over Lite.php.

    Is this possible?

    Many thanks
    Andy
  4. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Sure possible. Fix is the same :
    Add this setting to php.ini
    session.cookie_domain = .yourdomain.com
  5. cleerclouds

    cleerclouds Member

    Joined:
    Nov 30, 2011
    Messages:
    42
    Sure?, because the subdomain has an own IP, with an own webfolder,
    with no right for the other folder of the main domain.

    Many thanks
    Andy
  6. cleerclouds

    cleerclouds Member

    Joined:
    Nov 30, 2011
    Messages:
    42
    Is this now possible for a subdomain with an own IP and account?

    Many thanks
    Andy
  7. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    IP and folder where you have subdomain files are really doesn't matter.
    What is important is session settings. They should be the same exactly. Since aMember overrride session_save_handler, the only one main setting which you need to check is session.cookie_domain.
    It should be set to .yourdomain.com, have you tried this?

Share This Page