user_error message not appearing

Discussion in 'Troubleshooting' started by kenmoody, May 30, 2015.

  1. kenmoody

    kenmoody aMember Pro Customer

    Joined:
    Aug 21, 2012
    Messages:
    26
    I am using the following shortcode to protect content on specific pages on my wordpress site.

    [am4show have='g1;' guest_error='sub_message' user_error='sub_message’]

    Guests and non signed in members see the appropriate error message.

    Users who have a current, active subscription which is part of group1 (g1) are able to view the protected content.

    However, users who have an expired membership do not see anything. Not the error message, not the content.

    Based on my understanding of how shortcodes work, they should see the 'sub_message' eroor message. Am I missing something? Should I be doing something differently?

    Thanks,

    KM
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Yes expired user should see the same error message.
    Try to amember CP -> Rebuild DB -> Rebuild Core Database.
    If this helps, make sure that you have external cron job configured and working.
  3. kenmoody

    kenmoody aMember Pro Customer

    Joined:
    Aug 21, 2012
    Messages:
    26
    Alexander, thank you for the reply. No this did not help. Still not seeing the error message.
    Thanks for your help,

    KM
  4. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Please contact us in helpdesk, provide access info and a way to see that issue.

Share This Page