user not seeing specific page

Discussion in 'Troubleshooting' started by chris_nerat, Oct 12, 2015.

  1. chris_nerat

    chris_nerat Member

    Joined:
    Sep 21, 2015
    Messages:
    42
    I have 3 products setup – One is a 3 month paid in full, one is a 3 month billed monthly, and one is a day 10 free trial. All 3 products have access to the same protected pages and video content. The only difference is that the 10 day free trial expires after 10 days.

    Both of the 3 month products work fine – no issues with them. However, the 10 day free trial is not seeing a specific page that it should. It can see each individual video by entering in the specific URL to that day's video, but when they navigate to the page where all the videos should be available, they get a blank page.

    The page is a Custom Post Type and is located here:

    https://www.fitnessworkz/daily-lessons

    The pic named “lessons 1” is what either of the monthly products see when they are logged in – there is a listing of all the videos -- this is an example of how it should work.

    [​IMG]

    The pic named “lessons 2” is what you see when logged in as a 10 free trial – why can’t I see the page of videos the same as the monthly products?

    [​IMG]

    The page protection settings for each video in WordPress (under the "Daily Lessons" CPT) are the same as the monthly products, so I don't understand why one account gets a blank page and others do not.
  2. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,642
    Do you mind to attach screenshot of your protection settings for this page?
  3. chris_nerat

    chris_nerat Member

    Joined:
    Sep 21, 2015
    Messages:
    42
    Sure, but the page itself is not visible in WP...it is a CPT and not listed in site pages -- only as a menu item on the left sidebar. Here is a pic though of the individual page settings within the Daily Lessons CPT

    [​IMG]
  4. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Chris,
    I've fixed this temporary. I will implement fix into a plugin and will send you fixed file through helpdesk.
  5. chris_nerat

    chris_nerat Member

    Joined:
    Sep 21, 2015
    Messages:
    42
    Thank you, Alexander -- much appreciated!

Share This Page