Unusual page in Member's profile area

Discussion in 'Troubleshooting' started by ckissack, Dec 3, 2012.

  1. ckissack

    ckissack aMember Pro Customer

    Joined:
    Oct 16, 2012
    Messages:
    7
    I have been busy setting up Amember Pro, recently purchased, 4.2.13.

    I have customised the member's area to my satisfaction but the "Add/Renew Subscription" page looks strange. Below a message "You are logged in as test22 (a test username)" there is the top and bottom sections of a renew subscription form, with text at top and "next" button at bottom. See image.

    Surely there shouldn't be any part of the order form visible? Why display just the "next" button? If I click on the "next" button a receive a "you haven't selected any products". Perhaps I'm missing something here?

    Attached Files:

  2. thehpmc

    thehpmc aMember Pro Customer

    Joined:
    Aug 24, 2006
    Messages:
    901
    Might help if you posted up code you now have, also indicate what changes you have made.

    What do the other tabs look like?
  3. ckissack

    ckissack aMember Pro Customer

    Joined:
    Oct 16, 2012
    Messages:
    7
    Thanks for your reply. I haven't edited the code here. This is how it looks when I viewed the page for the first time. I'm sorry, it was not very clear of me to write "I've been busy editing" - that really applies to other pages.

    I did edit the javascript menu across top (shortened "Add/Renew Subscription" text, to "Renew Subscription") didn't mess with the code.

    Other tabs look fine, after some editing on the "main" page.

    I would have thought that something along the lines of "Your subscription doesn't expire for another xx months" would have been printed here.
  4. ckissack

    ckissack aMember Pro Customer

    Joined:
    Oct 16, 2012
    Messages:
    7
    OK I get it. They're greyed out when logged in in the form editor and this can't be edited, and perhaps doesn't need to be. I need to add other features eg. product to the form for it to make sense. Thanks for the reply anyway thehpmc always great to have a helpful and quick response on a support forum (especially when it's a stupid question!) :)

Share This Page