SQL connections error... open ticket urgent

Discussion in 'aMember Pro v.4' started by sifucicero, Jun 18, 2013.

  1. sifucicero

    sifucicero aMember Pro Customer

    Joined:
    Aug 27, 2010
    Messages:
    24
    Alex,

    This is an open ticket #YIN-43435-898 with access information provided for your investigation.

    Alex,
    Here is the MySQL error we are getting in our error log:
    Time:
    06/18/13, 09:00 AM
    Message:
    SQLSTATE[42000] [1203] User sifucac_chienerg already has more than 'max_user_connections' active connections at /home4/sifucac/public_html/am/library/Am/App.php line 963(1203) in query: new PDO
    Expanded:
    Exception Am_Exception_PluginDb
    Am_Protect_Databased->dbErrorHandler [ library/DbSimple/Generic.php : 1266 ]
    DbSimple_Generic_LastError->setErrorHandler [ library/Am/Protect/Databased.php : 312 ]
    Am_Protect_Databased->getDb [ application/default/plugins/protect/wordpress/api.php : 44 ]
    WordpressAPI->getDb [ application/default/plugins/protect/wordpress/api.php : 53 ]
    WordpressAPI->get_option_cache [ application/default/plugins/protect/wordpress/api.php : 65 ]
    WordpressAPI->get_option [ application/default/plugins/protect/wordpress/api.php : 23 ]
    WordpressAPI->__construct [ application/default/plugins/protect/wordpress/wordpress.php : 501 ]
    Am_Protect_Wordpress->getWP [ application/default/plugins/protect/wordpress/wordpress.php : 281 ]
    Am_Protect_Wordpress->getLoggedInRecord [ library/Am/Protect/Databased.php : 429 ]
    Am_Protect_Databased->onAuthCheckLoggedIn [ library/Am/Event.php : 577 ]
    Am_Event->call [ library/Am/Event.php : 600 ]
    Am_Event->handle [ library/Am/Hook.php : 200 ]
    Am_Hook->call [ library/Am/Auth/User.php : 186 ]
    Am_Auth_User->checkExternalLogin [ application/default/controllers/SignupController.php : 68 ]
    SignupController->indexAction [ library/Am/Controller.php : 139 ]
    Am_Controller->_runAction [ library/Am/Controller.php : 116 ]
    Am_Controller->dispatch [ library/Zend/Controller/Dispatcher/Standard.php : 295 ]
    Zend_Controller_Dispatcher_Standard->dispatch [ library/Zend/Controller/Front.php : 954 ]
    Zend_Controller_Front->dispatch [ library/Am/App.php : 1675 ]
    Am_App->run [ index.php : 43 ]

    We have quite a few of the the same errors coming in prior but on different urls. Please help us get this figured out.
    Thanks so much
    [​IMG]
  2. sifucicero

    sifucicero aMember Pro Customer

    Joined:
    Aug 27, 2010
    Messages:
    24
    We have spoke with Host Gator and have access to the php.ini file. Is the mysql connect timeout value the same as what you are talking about with the MySQL Sleep Timeout? If so, it is set at 60, what is the optimal value it needs to be set at for aMember.
  3. alex

    alex Administrator Staff Member

    Joined:
    Jan 24, 2004
    Messages:
    6,020
    There is nothing to do with php.ini

    HostGator have to increase limits of simultaneous MySQL connectsion in MySQL config. You (and we) cannot fix this problem.
  4. sifucicero

    sifucicero aMember Pro Customer

    Joined:
    Aug 27, 2010
    Messages:
    24
    Hello Alex and Anton,

    My "new" developer looked at past support tickets on this exact same sql connections issue.

    We have received two different answers from Alex and Anton for the same SQL problem. Right now "we are not confident to change the settings" until we understand which one is correct.

    Please advise:

    Which answer is correct? Then let us know what the right answer what should it be set at...


    Do you want us to change:

    Alex's answer: max_user_connections MySQL
    Reference: EPY-51928-469 Updated: 1 year ago
    or

    Anton's answer: mysql sleep timeout or
    Anton other answer: mysql connect timeout
  5. sifucicero

    sifucicero aMember Pro Customer

    Joined:
    Aug 27, 2010
    Messages:
    24
    Alex,

    I read your answer. I've sent this on to my developer this morning. This is a brand new developer and he is as confused as my past developer that tried to work on this issue.

    I'm tired and not feeling well today especially trying to understand why a year ago the answer was different for the exact same SQL error. Plus, I received a different answer in a Amember support ticket as referenced below.

    Please guys help us out here... our business is very important to many people who depend on us. We just want to change the right setting or ask HostGator to change the right setting.

    Sincerely,
    Cindy Cicero

  6. alex

    alex Administrator Staff Member

    Joined:
    Jan 24, 2004
    Messages:
    6,020
    1. Any of these settings will help.
    2. This error has nothing specific for aMember. ANY script using MySQL database will have same problems on this host. That is work for system administrator / hosting support to check roots of this issue. They have all necessary tools and access details to do that. We have no root access to server and may only guess possible solutions.
  7. sifucicero

    sifucicero aMember Pro Customer

    Joined:
    Aug 27, 2010
    Messages:
    24

    Thank you --- I will update my developer.
  8. tokazama2

    tokazama2 aMember Pro Customer

    Joined:
    Feb 7, 2013
    Messages:
    51
    I am having the same error that you had previously. I am also on HostGator. Were you able to find a resolution to this problem?
  9. sifucicero

    sifucicero aMember Pro Customer

    Joined:
    Aug 27, 2010
    Messages:
    24
    We tried to increase one setting at a time to see the results and we did not have any success. I believe a vps or a dedicated server may be the solution however this is a guess.
  10. miso

    miso aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    542
    If you are having these issues you need to increase the amount of RAM assigned to your webhosting account, as every user creates a mysql connection (or a few) and having a few dozen users creates a certain amount of simultaneous connections that is sometimes greater than what your host allows you to (Hostgator on their shared hosting plans, for example).

    If upgrading to VPS doesn't help (even after your host optimizes the mysql max connections # and all the other related memory settings like php max memory, etc) you might have outgrown that setup and need to upgrade to either semi-dedicated or dedicated.

    Take a look at WiredTree's Hybrid plans before jumping into a full on dedicated server (as it's less than half the price for pretty much the same thing) and you get plenty more resources to deal with than a regular VPS will allow you -> http://www.wiredtree.com/ (I host all of my client sites with them - couldn't recommend them more and speak more highly of them so far).
  11. mastermarketingclub

    mastermarketingclub New Member

    Joined:
    Nov 9, 2015
    Messages:
    2
    Hi,

    I also have this problem, I am running PHP 5.5 on an CentOS v.6 linux server. All my other web application using MySQL and the PHPMyAdmin are all connecting fine to MySQL only Setup with aMember is having trouble connecting..

    It is having trouble with the user privelages i have double checked and even created an new database, still wont connect...

    Regards,
    Conor
  12. mastermarketingclub

    mastermarketingclub New Member

    Joined:
    Nov 9, 2015
    Messages:
    2
  13. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,660

Share This Page