Security Note 10 applies to?

Discussion in 'Setting-up protection' started by janh, Aug 11, 2017.

  1. janh

    janh aMember Pro Customer

    Joined:
    Apr 4, 2017
    Messages:
    23
    Hello,

    Just received Security Note 10 today, it says:

    "Your site may be affected if you are using aMember plugin for WordPress or if you are using Lite.php API for custom integration."

    Does this mean that my site is not affected by the problem if I'm not using WordPress or Lite.php API?

    That would be good, then I wouldn't need to worry about upgrading.

    Thanks!
  2. ntc69

    ntc69 Member

    Joined:
    Apr 9, 2005
    Messages:
    52
    I agree, there needed to be more details about this. Many mentions of Wordpress so is it only WP sites that need this??
  3. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    Hello,

    It is better to apply it anyway. At least just replace file Lite.php (it is enough).

    Best Regards.
  4. jamesj

    jamesj New Member

    Joined:
    Aug 15, 2017
    Messages:
    1
    I have the same issue. We are using aMember with Joomla....(and aMember is receiving active payments)

    I don't know if that file is a wordpress specific file and will screw up my system or not.
    Can someone let me know their perspective?

    Thanks,
  5. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    Just replace your file with new one (fixed version) and do not worry about this issue.

    Best Regards.
  6. janh

    janh aMember Pro Customer

    Joined:
    Apr 4, 2017
    Messages:
    23
    Thank you Caesar for your reply!

    I replaced Lite.php only.

    What would be a good way to test aMember so the new file works ok?
  7. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    It works ok. Do not worry about it.

Share This Page