Redirect to another URL when Unauthorized Access Occurs

Discussion in 'Setting-up protection' started by pjman, Nov 20, 2013.

  1. pjman

    pjman Member

    Joined:
    Oct 18, 2013
    Messages:
    37
    Using latest amember 4.x build.

    When a non-logged in user visits any of my Protected directories, they are sent to my login page.

    This is killing my conversion to sales rates.

    I would like them to be sent to another URL (squeeze page).

    I don't see any way to do this without using Word Press.

    I saw a similar thread where the the file "no-access.phtml" was mentioned. I guess that is the template that Unauthorized Accesses are sent, but it doesn't look like anything I can easily edit.

    Any ideas guys?
  2. femur

    femur aMember Pro Customer

    Joined:
    Mar 9, 2009
    Messages:
    24
    A late answer, but yes! This has been added fairly recently to amember 4. Now when you protect a folder, you can specify a specific redirect URL for each product (they can all be different). This is a fantastic addition to amember! :)
  3. wckicksass

    wckicksass aMember Pro Customer

    Joined:
    Aug 5, 2012
    Messages:
    21
    I'm trying to do this now. Can't figure it out. Where is that at? Can you give me a print screen please :)
  4. laoniu

    laoniu New Member

    Joined:
    Mar 14, 2014
    Messages:
    6
    I'm trying to do this now.\


    ________________
    Aion kinah
  5. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,659
    This settings is available on protect folder screen. aMember CP -> Protect Content -> Folders (new/edit)
    Please check setting No Access URL
  6. pjman

    pjman Member

    Joined:
    Oct 18, 2013
    Messages:
    37
    Tried to enter a URL in there and even rebuilt the folder database right after, but it is still redirecting to the "noaccess" template. Any pointers?
  7. pjman

    pjman Member

    Joined:
    Oct 18, 2013
    Messages:
    37
    Regardless if I change the No Access URL setting under the protected folder settings or edit the "noaccess.phtml" I can't edit the page users are redirected to when they try to access the protected folder.
  8. soyoukan

    soyoukan New Member

    Joined:
    Aug 8, 2015
    Messages:
    10
    the admin had to tweak something for me, had similar problem... create ticket for help/!

Share This Page