Rebills not showing payments page

Discussion in 'Payments processing' started by kriss, Feb 18, 2013.

  1. kriss

    kriss Member

    Joined:
    Feb 5, 2013
    Messages:
    48
    Are rebills supposed to show up on the payments page? Mine are not and it seems aMember is not receiving the rebill information correctly.
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Yes all rebills should be available in aMember CP -> Payments report.
    What payment systems do you use? Do you see any errors in aMember CP -> Logs -> Invoice log?
  3. kriss

    kriss Member

    Joined:
    Feb 5, 2013
    Messages:
    48
    I'm using CCBill and Zombaio. There are a bunch of errors in the log that look like:

    ccBill Datalink Error: Transaction ccbill-0113089104000026059 is already handled while handling line: "REBILL","924518","0000","0212355401000012252","2013-02-18","0113089104000026059","29.95"

    When expanded:

    call_user_func [ library/Am/Event.php : 527 ]
    Am_Event->call [ library/Am/Event.php : 550 ]
    Am_Event->handle [ library/Am/Hook.php : 200 ]
    Am_Hook->call [ library/Am/App.php : 855 ]
    Am_Cron::checkCron [ application/default/controllers/CronController.php : 29 ]
    CronController->indexAction [ library/Am/Controller.php : 139 ]
    Am_Controller->_runAction [ library/Am/Controller.php : 116 ]
    Am_Controller->dispatch [ library/Zend/Controller/Dispatcher/Standard.php : 295 ]
    Zend_Controller_Dispatcher_Standard->dispatch [ library/Zend/Controller/Front.php : 954 ]
    Zend_Controller_Front->dispatch [ library/Am/App.php : 1681 ]
    Am_App->run [ index.php : 43 ]
  4. kriss

    kriss Member

    Joined:
    Feb 5, 2013
    Messages:
    48
    And I also just noticed:

    ccBill Datalink error: unable to find invoice for this record: "EXPIRE","924518","0000","0212355401000012252","2013-02-18","2013-02-11","N"
  5. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Search for 0113089104000026059 in your amember CP -> Payments report if you can find such transaction just ignore these errors because transaction was activated already.
    That one is generated when amember is unable to find original invoice for rebill. if that invoice/payment was added manually make sure that payment's receipt_id is set correct value (0212355401000012252 in this situation)
  6. kriss

    kriss Member

    Joined:
    Feb 5, 2013
    Messages:
    48
    I can't find the numbers in the report.
  7. kriss

    kriss Member

    Joined:
    Feb 5, 2013
    Messages:
    48
    Any ideas? It's 3:30 AM EST here :)
  8. kriss

    kriss Member

    Joined:
    Feb 5, 2013
    Messages:
    48
    I've got to get to bed now, can't stay up any longer. You have the login information in the ticket I submitted, can you please have a look. Rebills haven't worked since you finished the installation last week.
  9. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    This was fixed yesterday. Just for reference problem was in incorrect import
  10. kriss

    kriss Member

    Joined:
    Feb 5, 2013
    Messages:
    48
    Yes all is working perfectly now. :)

Share This Page