Protection "Broken" With W3TC on iPad (fine on PC)

Discussion in 'Setting-up protection' started by rd2711, Jul 6, 2012.

  1. rd2711

    rd2711 New Member

    Feb 21, 2009
    I have W3 Total Cache working with S3/Cloudfront beautifully - until I tried to access a protected link on my iPad.

    One click and it goes to the login screen, as it should. However, if I navigate back and click on the same link again it does NOT go to the login, instead it shows the content. This, even with all browser caching disabled in W3TC.

    If I completely disable W3TC then protection works as it should. However, that's not an ideal solution.

    With the exact same settings (Caching on), Chrome, FF and Safari all protect the content, while iPad Safari does not protect it. Can anyone else confirm this issue or suggest a fix? I have tried both to protect the category as well as the exact content and in both cases I get the same resulting protection failure.
  2. skippybosco

    skippybosco CGI-Central Partner Staff Member

    Aug 22, 2006
    I suspect you have exceptions in place so that W3TC does not cache your protected pages? If so, be sure those same exceptions exist for the mobile agents.

Share This Page