PhpBB Integration not working

Discussion in 'Integration' started by loachman, Dec 2, 2011.

  1. loachman

    loachman Guest

    Joined:
    Aug 14, 2007
    Messages:
    23
    I have installed the plugin. However after hitting save I get not more prompts to add users to the forum or anything. Furthermore when I login I am not logged into the forum.

    Here is a screen of my phpbb settings.

    http://www.freeimagehosting.net/90b2b
  2. davidm1

    davidm1 aMember User & Partner

    Joined:
    May 16, 2006
    Messages:
    4,435
    Have you added the phpbb user group to the specific amember products?

    David
  3. loachman

    loachman Guest

    Joined:
    Aug 14, 2007
    Messages:
    23
    Not sure what you mean David. Can you explain a little more.

    Thanks
  4. davidm1

    davidm1 aMember User & Partner

    Joined:
    May 16, 2006
    Messages:
    4,435
    Go into a product in amember, and add the phpbb3 group to it- its an option if the plugin has been installed properly.

    then you do a rebuild and users with the products with phpbb3 groups set will be copied over.

    David
  5. loachman

    loachman Guest

    Joined:
    Aug 14, 2007
    Messages:
    23
    I do not see any options to add a group in the product.
    I do not have a mysql password set when I installed the phpbb plugin. I am on localhost. Would that have something to do with it?
  6. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    These options are not in Product Settings anymore(I see that you have aMember v4 installed, right? )
    Go to amember CP -> protect Content -> Integrations -> new record.
    Then select plugin, group and access record and click save.
    After this will be done, click aMember CP -> rebuild Db -> phpBb database this will transfer all active users from amember to phpBB.
  7. loachman

    loachman Guest

    Joined:
    Aug 14, 2007
    Messages:
    23
    Thanks Alexander,

    That seems to have gotten the protection and login working. However when I log out of phpBB it does not log me out of amember it seems. Also to ask now instead of starting many threads, how to send them back to my index page when they have logged out of PHPBB. Will I need to hack into phpBB core to do this?

    One final thing it seems to not have added my Admin account to phpBB, I have protected that folder so I cannot access it. Do I need to add a regular user and assign him an admin role before protecting that folder.

    Thanks
  8. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    This will not work. You need to use aMember's logout link.

    Well I believe there should be an option in phpBb. Something like redirect after logout.
    Can't say this exactly because don;t have working phpBB installation.

    admin account will not be added. You have to create regular user account in order to access folder where you have phpBB installed.
  9. loachman

    loachman Guest

    Joined:
    Aug 14, 2007
    Messages:
    23
    This is a big deal, is there no way to accomplish it? I will remove the logout links from the header if I need to,
    but it would be nice if it is possible to do this. I thought AMember plugins worked both ways?

    Thanks
    James
  10. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    James,
    plugin can do this:
    1. if user logged in third-party script, plugin will login that user into amember.
    2. When user logout from amember he will be logged on third-party script
    3. When user login into aMember, he will be logged in to third-party script.

    So you need to change logout link so it will point to aMember logout.
  11. fmagusto

    fmagusto Member

    Joined:
    Nov 30, 2011
    Messages:
    245
    I installed the plugin PHPBB,

    Go to amember CP -> Protect Content -> Integration -> new record.
    Then select plugin, group and record access and click save.

    but when I go to the forum, I'm not logged in
    user. Do you have an idea?
  12. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Contact us in helpdesk and provide access info. We will troubleshoot this issue.
  13. wplook

    wplook New Member

    Joined:
    Jun 17, 2011
    Messages:
    8
    I have the some problem like Fmagusto. How to solve it?
  14. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Hi,
    Please check this:
    1. Check cookie setting sin plugin configuration and make sure they are the same as in phpbB.
    2. Are you able to login using amember's login password into phpBB itself? If no -> rebuild Database
    If yes Make sure that both amember and phpBB have the same domain name in Root url. (does not matter with or without www? but should be the same for both scripts )
    If nothing helps contact us in helpdesk.
  15. wplook

    wplook New Member

    Joined:
    Jun 17, 2011
    Messages:
    8
    My passwords, didn't save to PHPBB after rebuilding DB. I understand that this thing is normal. After User login it works.
  16. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Yes correct. aMember do not store plain/text passwords anymore, so when you rebuild DB, there is no password available.
    But when you login, aMember get password from user and update third-party script databases.
  17. jacks

    jacks New Member

    Joined:
    Dec 30, 2011
    Messages:
    3
  18. jacks

    jacks New Member

    Joined:
    Dec 30, 2011
    Messages:
    3
    I have a mybb forum and I want to integrate it with the amember but the problem is that I am not able to integrate that both login and I have to register and login in both mybb and amember.I want only one register and only one login and want to access both amember and mybb with single login....Anybody has the better ideas...I had already perform all the above things but not working.If Anybody knows the proper answer from all over the world they can suggest me any time.
  19. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Did you setup mybb integration at aMember CP -> Protect Content -> Integrations ?
  20. jacks

    jacks New Member

    Joined:
    Dec 30, 2011
    Messages:
    3
    ya i have set up it twice but still not working...wht to do now?......alexander

Share This Page