PayPal's IPN Reporting to the Wrong URL

Discussion in 'Payments processing' started by bibbott, Jul 6, 2012.

  1. bibbott

    bibbott aMember Pro Customer

    Joined:
    May 27, 2010
    Messages:
    9
    Running into a very weird issue here, and hoping the smart folks in the forum here can offer some help.

    Using aMemberPro with PayPal. About 6 months ago, during the 4.x upgrade, I had to move the aMember and protected files from the old location to a new one because the protected directories weren't being recognized. Got everything working, or so I thought.

    In PayPal, I have the IPN URL as:
    http://coverville.com/adminfolder/payment/paypal/ipn
    (changed slightly for protection)

    And that's the same URL that aMember shows at the bottom of the PayPal plugin page.

    However, PayPal is sending some payments through, and not others. And on the ones that are not making it through, it appears to be using the old IPN URL:
    http://www.coverville.com/admin/plugins/payment/paypal_r/ipn.php
    (also changed slightly for protection)

    I first contacted PayPal about this, and they say that it's the URL that is getting fed from aMember. I've tried setting up an .htaccess file to redirect the IPNs from one to the other, and that only seems to work sporadically.

    Where could aMember be feeding PayPal the other URL, and how can I get into the inner workings and change it?
  2. davidm1

    davidm1 aMember User & Partner

    Joined:
    May 16, 2006
    Messages:
    4,435
    Could be in the paypal sites IPN settings? Did you check your paypal configuration?

    David
  3. bibbott

    bibbott aMember Pro Customer

    Joined:
    May 27, 2010
    Messages:
    9
    In PayPal, under Profile > IPN Settings, I've got the correct URL. But is there another place in my PayPal profile that it would be stored? I was on the phone with PayPal, and they told me I had the correct URL in IPN settings (which is the same as the one at the bottom of the PayPal settings page in aMember). They said that the bad URL is getting posted via aMember.
  4. bibbott

    bibbott aMember Pro Customer

    Joined:
    May 27, 2010
    Messages:
    9
    Anyone else have suggestions? It's still not reporting correctly.

Share This Page