PayPal not Working (4.x) (why an SSL log error entry?)

Discussion in 'Installation' started by dblack6047, Aug 24, 2012.

  1. dblack6047

    dblack6047 aMember Pro Customer

    Feb 7, 2009

    Since my upgrade a few weeks ago from 3.x to 4.2.7 and then recently to 4.2.9 I have been working very hard to find out why the PayPal IPN will not work. I have used PayPal with aMember 3.x for years with no problems.

    I have checked, rechecked and checked everything both in aMember and on the PayPal site and I keep getting the same Error notifications after either a new member signs up and uses PayPal to pay or when an older member renews their subscription using PayPal.

    In the aMember version 4.2.x error log it shows "Need OpenSSL support for https:// requests" resulting from the URL "…member/payment/paypal/ipn".

    I have seen other references to this SSL oddity in the Forum while doing research but there has been no answer. I created a helpdesk ticket two days ago with aMember support but no response yet from the aMember admin either (may be on vacation possibly) so I am hoping someone within the Forum might have an answer.

    Prior to 4.x I did not use SSL but because of the above oddity where it references SSL I decided to install SSL and created certificates with PayPal. Still, I am getting the same error log entry with each payment. Frankly, I do not think having or not having SSL is the problem at all.

    I now end up having to manually finish the payment for each new or renewing member. I have tried forcing the IPN to be resent from the PayPal website but all I see in my apache http logs is a code 200 successfull connection from PayPal. (Note: HTTPS is not even being used by PayPal)

    When I upgraded and installed the plugin for PayPal 4.x I observed at the bottom of the screen the aMember software said I must enter "" on the PayPal website which I did. (note: hid my real domain name on purpose)

    What I am also confused on is that in my aMember website there is no such directory or file "amember/payment/paypal/ipn" anywhere so I am confused on why I would use that particular directory.

    I only have the following directories under aMember directory such as:

    - application
    - data
    - library
    - setup

    I can only guess its just a false or null entry that aMember software wants me to use on the PayPal website just because something is needed by PayPal.

    Just in case this helps ... below is the expanded error on the problem mentioned with the PayPal plugin:

    Exception HTTP_Request2_LogicException
    HTTP_Request2_Adapter_Socket->connect [ library\pear\HTTP\Request2\Adapter\Socket.php : 154 ]
    HTTP_Request2_Adapter_Socket->sendRequest [ library\pear\HTTP\Request2.php : 923 ]
    HTTP_Request2->send [ library\Am\Paysystem\Transaction\Paypal.php : 90 ]
    Am_Paysystem_Transaction_Paypal->validateSource [ library\Am\Paysystem\Transaction\Incoming.php : 285 ]
    Am_Paysystem_Transaction_Incoming->validate [ library\Am\Paysystem\Transaction\Abstract.php : 48 ]
    Am_Paysystem_Transaction_Abstract->process [ library\Am\Paysystem\Transaction\Incoming.php : 231 ]
    Am_Paysystem_Transaction_Incoming->process [ library\Am\Paysystem\Abstract.php : 430 ]
    Am_Paysystem_Abstract->directAction [ application\default\controllers\DirectController.php : 29 ]
    DirectController->__call [ library\Am\Controller.php : 118 ]
    Am_Controller->dispatch [ library\Zend\Controller\Dispatcher\Standard.php : 295 ]
    Zend_Controller_Dispatcher_Standard->dispatch [ library\Zend\Controller\Front.php : 954 ]
    Zend_Controller_Front->dispatch [ library\Am\App.php : 1518 ]

    Can anyone please assist or provide a suggestion?

    Thank You,


Share This Page