nothing back from paypal

Discussion in 'Troubleshooting' started by ccwjames, May 1, 2015.

  1. ccwjames

    ccwjames Member

    Joined:
    Sep 11, 2014
    Messages:
    430
    i have a month membership and a special 24 hr membership for events

    i got on my phone 2 pop ups for one user that has just brought both

    one shows as paid under his name, yet the other says pending?
    when i go to log it says

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    loads of xml stuff and also i used to get a email telling me someone brought somthing, this time im not?
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Do you see completed payment for this user in your amember Control panel?
    Do you have Notifications about completed payment enabled in amember CP -> Setup-> Email?
  3. ccwjames

    ccwjames Member

    Joined:
    Sep 11, 2014
    Messages:
    430
    Looks like an invalid IPN post - no Invoice# passed

    Exception Am_Exception_Paysystem_TransactionEmpty
    Am_Paysystem_Transaction_Incoming->autoCreate [ library/Am/Paysystem/Transaction/Incoming.php : 302 ]
    Am_Paysystem_Transaction_Incoming->validate [ library/Am/Paysystem/Transaction/Abstract.php : 48 ]
    Am_Paysystem_Transaction_Abstract->process [ library/Am/Paysystem/Transaction/Incoming.php : 246 ]
    Am_Paysystem_Transaction_Incoming->process [ library/Am/Paysystem/Abstract.php : 463 ]
    Am_Paysystem_Abstract->directAction [ application/default/controllers/DirectController.php : 28 ]
    DirectController->__call [ library/Am/Controller.php : 118 ]
    Am_Controller->dispatch [ library/Zend/Controller/Dispatcher/Standard.php : 295 ]
    Zend_Controller_Dispatcher_Standard->dispatch [ library/Zend/Controller/Front.php : 954 ]
    Zend_Controller_Front->dispatch [ library/Am/App.php : 1916 ]
    Am_App->run [ index.php : 43 ]
  4. ccwjames

    ccwjames Member

    Joined:
    Sep 11, 2014
    Messages:
    430
    under that
    ... temporary failure

    Exception Zend_Mail_Protocol_Exception
    Zend_Mail_Protocol_Abstract->_expect [ library/Zend/Mail/Protocol/Smtp/Auth/Login.php : 95 ]
    Zend_Mail_Protocol_Smtp_Auth_Login->auth [ library/Zend/Mail/Protocol/Smtp.php : 217 ]
    Zend_Mail_Protocol_Smtp->helo [ library/Zend/Mail/Transport/Smtp.php : 200 ]
    Zend_Mail_Transport_Smtp->_sendMail [ library/Zend/Mail/Transport/Abstract.php : 348 ]
    Zend_Mail_Transport_Abstract->send [ library/Am/Mail.php : 373 ]
    Am_Mail_Queue->send [ library/Zend/Mail.php : 1194 ]
    Zend_Mail->send [ library/Am/Mail.php : 117 ]
    Am_Mail->send [ library/Am/Mail/Template.php : 149 ]
    Am_Mail_Template->send [ application/helpdesk/library/Am/Helpdesk/Strategy/Admin.php : 66 ]
    Am_Helpdesk_Strategy_Admin->onAfterInsertMessage [ application/helpdesk/library/Am/Helpdesk/Controller.php : 363 ]
    Am_Helpdesk_Controller->addMessage [ application/helpdesk/library/Am/Helpdesk/Controller.php : 375 ]
    Am_Helpdesk_Controller->reply [ application/helpdesk/library/Am/Helpdesk/Controller.php : 197 ]
    Am_Helpdesk_Controller->replyAction [ library/Am/Controller.php : 139 ]
    Am_Controller->_runAction [ library/Am/Controller.php : 116 ]
    Am_Controller->dispatch [ library/Zend/Controller/Action.php : 568 ]
    Zend_Controller_Action->run [ library/Am/Controller/Pages.php : 124 ]
    Am_Controller_Pages->renderPage [ library/Am/Controller/Pages.php : 73 ]
    Am_Controller_Pages->__call [ library/Am/Controller.php : 118 ]
    Am_Controller->dispatch [ library/Zend/Controller/Dispatcher/Standard.php : 295 ]
    Zend_Controller_Dispatcher_Standard->dispatch [ library/Zend/Controller/Front.php : 954 ]
    Zend_Controller_Front->dispatch [ library/Am/App.php : 1916 ]
    Am_App->run [ index.php : 43 ]
  5. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    This indicates a problem in mail sending method configuration.
    Check it configuration in amember CP -> Setup -> Email and test it to make sure it is working.
  6. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    This message usually generated when amember receives IPN message which is not related to any invoice in the system.
    For example when you sent money from your paypal account to someone.
  7. ccwjames

    ccwjames Member

    Joined:
    Sep 11, 2014
    Messages:
    430
    test is working all ok on email.

    is the second one then when i did a refund?
  8. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    That could be a temporary issue then.
    Yes if it was processed for payment which wasn't registered in amember.

Share This Page