My PayPal IPN settings not working properly

Discussion in 'Payments processing' started by weblizar, Jun 18, 2014.

  1. weblizar

    weblizar aMember Pro Customer

    Joined:
    Jun 3, 2014
    Messages:
    8
    Hi

    I have recently purchased and setup Amember with my website.

    Problem is after successful signup & PayPal payment by any customer, each customers account showing "pending" payment.
    Thats why each account required to activate manually trough admin account.

    I have followed the Amember PayPal Documentation, setup my Amember generated IPN URL into my PayPal account.

    Check below attachment screenshots of my PayPal IPN Settings

    Snap-1: IPN-url-setup-snap-a.png - https://www.dropbox.com/s/gaphmldgunwky3j/IPN-url-setup-snap-a.png

    Snap-2: IPN-url-setup-snap-b.png - https://www.dropbox.com/s/zyizdu8euuzofx0/IPN-url-setup-snap-b.png

    Snap-3: Amember-paypal-settings.png - https://www.dropbox.com/s/mpipgpn9mjhmpd4/amember-paypal-settings.png

    Please tell me what's going wrong with these settings?

    Please someone help me my customer making noise on me.

    Thanks
    Weblizar
  2. booforum

    booforum aMember Pro Customer

    Joined:
    May 20, 2005
    Messages:
    180
    I'm having this same issue.
    benkenobi77 likes this.
  3. thinkscripter

    thinkscripter New Member

    Joined:
    Jun 3, 2012
    Messages:
    6
    Same here.
    benkenobi77 likes this.
  4. academiathemes

    academiathemes aMember Pro Customer

    Joined:
    Nov 28, 2013
    Messages:
    9
    Hi,

    Make sure that you don't have any "deny from all" settings in your .htaccess, I know that I had this issue when I went live.
    I had a separate .htaccess file in the /amember/ folder, where I restricted access.
    Everything was working fine, but PayPal wasn't able to send the IPN notifications.

    Just wanted to share, you might have a different issue :)
  5. benkenobi77

    benkenobi77 aMember Pro Customer

    Joined:
    May 28, 2013
    Messages:
    5
    Having the same issue? Admins - is there a fix???
  6. alex

    alex Administrator Staff Member

    Joined:
    Jan 24, 2004
    Messages:
    6,020
  7. benkenobi77

    benkenobi77 aMember Pro Customer

    Joined:
    May 28, 2013
    Messages:
    5
    Here you go:

    Attached Files:

  8. benkenobi77

    benkenobi77 aMember Pro Customer

    Joined:
    May 28, 2013
    Messages:
    5
    Still need help admins
  9. weblizar

    weblizar aMember Pro Customer

    Joined:
    Jun 3, 2014
    Messages:
    8
    Hi All,

    After i submitted a support ticket HERE with my server access credential.

    Amember support guy fixed my problem so fast.

    And he replied to me:

    Thank you for access.

    There was issue with server configuration.
    I enabled two required PHP modules xmlwriter and xmlreader.
    It should works correctly for new payments now.

    Please go to your paypal account and resend IPN notification (which in status failed now).
    It will fix existing payments.

    Please let me know if you still have any issue with it.

    Best Regards.

    I hope this will help to you.

Share This Page