Moved site, no longer works

Discussion in 'Troubleshooting' started by clubmanplus850, Jun 30, 2015.

  1. clubmanplus850

    clubmanplus850 New Member

    Joined:
    Jun 30, 2015
    Messages:
    1
    Hi all,

    I have recently moved my site from a production server to a test system, to perform some maintenance, fine tuning and general evaluation.

    I followed this guide : http://www.amember.com/docs/Move_aMember_to_another_webhosting but it didn't completely work - everything was fine up til step 5, then from 9 on it was a failure.

    No amember URLs work anymore, amember/login, amember/register, amember/admin are all 404's.

    I have cleaned up a lot of permissions problems (there is a diference between the production and test user setup), but this has not seemed to fix the problem.

    Directories which I had protected on the production server, are no longer protected on my test server -> htaccess issue?

    I don't seem to find any logs on the issue, and have followed most of the threads on simillar issues to no avail. Any help would be appreciated.
  2. thehpmc

    thehpmc Member

    Joined:
    Aug 24, 2006
    Messages:
    901
    404 errors could be because aMember uses .htaccess to redirect to its various pages so if this function is not available your site will fail.

    Protection relies also on .htaccess.
  3. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    1. Check that you have mod_rewrite enabled on new server.
    2. Check that VirtualHost section in Apache's config has
    AllowOverride All
    line.
    3. Check aMember's htaccess file and make sure that URL which you have in RewriteBase line is correct.
  4. tooliedotter

    tooliedotter Member

    Joined:
    Apr 21, 2009
    Messages:
    59
    I am running Joomla and Amember on an AWS instance with virtual hosts, and I am having exactly the same problem. I just upgraded from v4.4.4 to v4.6.3, and it still gives me the mod_rewrite error.
    • I can see that mod_rewrite IS enabled in Apache
    • I have copied the .htaccess file to my server
    • The AllowOverride All is in the correct spot in the virtual hosts file
    • The RewriteBase /amember entry is uncommented in the /amember/.htaccess file
    In desperation, I tried re-running setup and saw the same error lines that ClubManPlus 850 saw at the top of the first installation screen.

    Any other ideas? I'm dead in the water until this is resolved.

    Toolie
  5. tooliedotter

    tooliedotter Member

    Joined:
    Apr 21, 2009
    Messages:
    59
    OK this turns out to be a VERY complex set of interactions between Amazon Web Services (AWS), Bitnami.com Linux/Apache/MySQL/PHP (LAMP) stacks, and Amember.
    1. Bitnami creates combinations of LAMP and publishes them for use on their hosting as well as disk images for AWS. I use them and have gotten to know their structure quite well. In their efforts to protect users on their web servers, they've taken to moving the contents of .HTACCESS files to configuration files in their Apache tree. Their <Directory > directives use AllowOverride None, which prevents HTACCESS files from doing their job.
    2. By so doing, they prevented the /amember/.htaccess file from working past the first level. So www.mydomain.com/amember would show up, but www.mydomain.com/amember/member would fail with a 404 because the mod_rewrite was prevented from working.
    3. I figured out a solution which the Bitnami folks might not approve of, but for now it solved the problem of the failing mod_rewrite AND it preserves the .HTACCESS file's functionality: https://community.bitnami.com/t/mod-rewrite-not-working-wordpress-install-plus-custom-app/30285/3
    If they amend my solution as I requested, then I will update the entry here. Meanwhile, hopefully others will benefit from what I figured out.

Share This Page