Modify the date for member products

Discussion in 'aMember Pro v.4' started by earthchanges, May 11, 2013.

  1. earthchanges

    earthchanges New Member

    Joined:
    Aug 22, 2006
    Messages:
    23
    The ability to modify the date for member products was added to the latest update. If a person buys two subscriptions you can now edit one for a future date. However when I change the date for that product I get the following error.
    DateTime::__construct() [datetime.--construct]: Failed to parse time string (Mon Feb 02 2015 00:00:00 GMT-0500 (Eastern Standard Time)) at position 41 (n): Double timezone specification
    If you change the end date first , then the start date it will give the error, but modify the dates. If you change the start date first it will not save.
    It also does not set the product to future, even if the start date is in the future. It remains an active product.

    I have added this to the bug tracker and was wondering if anyone knows of a quick fix. I have several member subscriptions to edit.
  2. scott_wa1

    scott_wa1 aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    54
    I'd like to bump this thread - I'm getting the same error but in my case, it won't modify the dates. They revert to the original date. Screenshot of the error is attached.

    In this case, it's one customer with one product with one invoice and one payment but I was trying to extend the access to a future date (like June 2017).

    -Scott

    Attached Files:

  3. miso

    miso aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    542
    Yep, been getting that sporadically on clients' installations too...
  4. skippybosco

    skippybosco CGI-Central Partner Staff Member

    Joined:
    Aug 22, 2006
    Messages:
    2,526
    What are your PHP timezone variables set to?
  5. miso

    miso aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    542

    server settings are correctly set to America/NewYork (Eastern Time)
  6. earthchanges

    earthchanges New Member

    Joined:
    Aug 22, 2006
    Messages:
    23
    My server time is also set to America/NewYork (Eastern Time)
  7. bgtheory

    bgtheory New Member

    Joined:
    Jan 22, 2010
    Messages:
    15
    What is the answer to this - I am having the same issue as Scott. Thanks!
  8. prachuab

    prachuab New Member

    Joined:
    Sep 4, 2008
    Messages:
    2
    I have the same problem. please advise how to resolve this issue.

    Thank you
  9. xtrememarketer

    xtrememarketer New Member

    Joined:
    Nov 9, 2011
    Messages:
    20
    I'm having the same problem. Any ideas?
  10. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Please check my reply in other thread. What aMember version do you have installed?
  11. aaughey

    aaughey New Member

    Joined:
    Jun 18, 2015
    Messages:
    1
    I know this one is old but I have the same issue and can't find the other thread, @alexander

Share This Page