Missing Something With Products

Discussion in 'Installation' started by kenmomentum, Nov 22, 2013.

  1. kenmomentum

    kenmomentum New Member

    Joined:
    Apr 1, 2011
    Messages:
    26
    Hello

    This is for version 4X

    New install and trying to figure out what is going on
    1. I amusing the sample subscription First Price 0.00 First Period Lifetime

    2. I created a user (Charley Brown

    3. I added sample Subscription to this user: Status is active

    4. I added access manually

    5. I login as charley from the top of amembernew/admin-user-payments/index/user_id/1

    6. When I go to the page it shows Your Membership Information. I only see Active Subscriptions and in the box it has the following: Sample Subscription - Lifetime

    7. My question is: How do I get a link to Charly's active subscription. In 3.X the list showed up as soon as I added it. I dd not have to have a protected folder for this subscription to show up for the user.

    8. What do I have to do to get this to show?
  2. crystalmedia

    crystalmedia Member

    Joined:
    Oct 15, 2013
    Messages:
    39
    I'm not sure what you mean by "link to his active subscription". Are you talking about a link to the protected content he should have access to?
  3. kenmomentum

    kenmomentum New Member

    Joined:
    Apr 1, 2011
    Messages:
    26
    Hello

    Yes, in 3X the user could have a subscription that WAS NOT in a protected area and she would have a link to that area.

    In 4X is the only way to have a subscription is have it in a protected area?

    I am upgrading my 3X aMember (actually replacing it with 4X in a new folder and new DB). I need to test this before it goes live but I have to make sure I do not over-write the existing .htaccess rewirtie in the existing folders.

    Hopefully you get the idea.

    This upgrade is not an easy one. But with the Upgrade to MySQL this is the only way to go. WHM will not upgrade with MySQL 5.0 so I waited to the last minute.
  4. hilary

    hilary aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    102
    To display a link that isn't protected in the members' area, you need Protect content > links - as described at https://www.amember.com/docs/Content/Links .

    Agreed, the upgrade to version 4 is not too easy - I had version-3-specific customisations throughout my whole website, so it all took me a very long time. It was worth it, though: version 4 makes all kinds of admin tasks a great deal easier.

Share This Page