max_user_connections?

Discussion in 'Troubleshooting' started by clarkbartron, Mar 28, 2004.

  1. clarkbartron

    clarkbartron Guest

    The script gets a fatal error max_user_connections have been reached. Is there somewhere in the script in which this can be changed? None of the other php scripts I use have this issue.
  2. alex

    alex Administrator Staff Member

    Joined:
    Jan 24, 2004
    Messages:
    6,020
    1. Download file amember/config.inc.php
    2. Edit it using text editor, add line before closing ?>
    $config['use_mysql_connect'] = 1;
    3. Remove file amember/config.inc.php on the FTP server.
    4. Upload your local (changed) copy of the file to FTP server.
  3. clarkbartron

    clarkbartron Guest

    Still getting the same error.
    Cannot connect to MySQL: User bizadvic_member has already more than 'max_user_connections' active connections

    Fatal error: Call to a member function on a non-object in /home/bizadvic/public_html/ecourse/private/common.inc.php on line 132
  4. alex

    alex Administrator Staff Member

    Joined:
    Jan 24, 2004
    Messages:
    6,020
    Oops - sorry, my mistake. Put line in config.inc.php
    $config['use_mysql_connect'] = 1;
    BEFORE line
    $config['db']['mysql'] = $pc;

    If it happens anyway, ask your webhosting support to to restart Apache webserver and send them error messsage as explanation why it is necessary.
  5. eeikbon

    eeikbon New Member

    Joined:
    Feb 14, 2011
    Messages:
    5
    What does that actually do
  6. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    When above setting will be enabled, aMember will not use persistent MySQL connections.

Share This Page