Joomla Plugin Setup

Discussion in 'Pre-Sales Questions' started by gavjof, Aug 4, 2010.

  1. gavjof

    gavjof New Member

    Joined:
    May 2, 2008
    Messages:
    5
    Hello,

    How up-to-date is the software and the integration plug-ins?
    Bearing in mind the Joomla Plugin still has reference to the old 1.0.x branch of Joomla and that Joomla 1.5.x is now up to 1.5.20.

    I posted here over 2 years back about an issue I had when trying out the aMember trial. I got no response and thus went off on a different route. I'd like to give aMember a shot at a new project I'm working on but I've hit the same stumbling block.

    See old thread here:
    http://www.amember.com/forum/showthread.php?t=7268

    When trying to setup the Joomla Database connection I receive the following error:
    Code:
    DB - [web55-myname.jos_] - incorrect value. Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-myname.jos_users LIMIT 1' at line 1
    It looks like it has an issue with the hyphen "-" in the database name.
    My host unfortunately creates it's names by taking my db name then and prefixing it with the web server number.

    I'd love to test out the functionality of this software but I need to be assured that the software is supported.
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Try to specify DB name and prefix in this format: `web55-myname`.jos_
  3. gavjof

    gavjof New Member

    Joined:
    May 2, 2008
    Messages:
    5
    Thank you for your response.

    Having tried what you suggested I now get a different error.
    Code:
    Access denied for user 'web55-myname'@'%' to database '`web55-myname`'
  4. gavjof

    gavjof New Member

    Joined:
    May 2, 2008
    Messages:
    5
    Okay so I've made some progress.

    I've created a new user in MySQL and then grated permission for both the Joomla and aMember databases. This seems to have done the trick.

    I have done the Rebuild DB and have my test user from aMember into my Joomla user list. Time for more testing.
  5. gavjof

    gavjof New Member

    Joined:
    May 2, 2008
    Messages:
    5
    The aMember plug-in is not working fully after I've tested it with the Joomla login module.

    The Links are as follows:

    Forgot your password
    /joomla/component/user/reset

    Forgot your username
    /joomla/component/user/remind

    Create an account
    /joomla/component/user/register

    The first two work and aMember redirect to:
    /amember/login.php?amember_redirect_url=/joomla/index.php

    However the create account link takes me to the Joomla registration form where I enter my details only to be redirected to the aMember registration page where I must enter them again.

    Am I supposed to create my own navigation direct to the aMember pages and disregard the Joomla login module?
  6. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Yes disable registrations in Joomla and create link that will redirect to ammeber for registration

Share This Page