How to add header logo and remove footer?

Discussion in 'aMember Pro v.4' started by jbildy, Nov 6, 2011.

  1. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
    1. I really need to figure out how to change the header for public views of pages.
    2. And to remover the footer with amember references.
    I've looked at http://v4.amember.com/docs/Themes_and_Templates

    But can't find anything about editing html templates.

    If I could change header height (to accomodate my logo) and header bg color and remove the footer, for (signup, profile, and all other member pages) that would be a good start.

    Can I just change files here?

    application/default/views/public/img/ Images
    application/default/views/public/css/ CSS files

    Want new header and no footer (at this stage) for all public viewable pages.

    Under "application/default/views/" all the phtml files are there. Do I have to change those files?

    Very confused.....
  2. gswaim

    gswaim CGI-Central Partner

    Joined:
    Jul 2, 2003
    Messages:
    641
    John B,

    All your questions have been about WordPress (WP). If you are using WP simply check this box on the WP configuration page in aMember and it will use the header and footer from your WP theme.

    [​IMG]
  3. alex

    alex Administrator Staff Member

    Joined:
    Jan 24, 2004
    Messages:
    6,020
    Yes, you can change these files, but it may be overwritten by upgrades. Better way:

    - create folder application/default/theme/mysite/
    - inside that folder create:
    application/default/theme/mysite/public/css/
    application/default/theme/mysite/public/img/
    - now select any files that you want to change from
    amember/application/default/views/
    and copy to approriate path at
    amember/application/default/themes/mysite/
    then edit.

    This way you will always keep track of what files you had changes, and it won't be overwritten after upgrade.
  4. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
    Is there a css file I can copy over, too? And alter from there?

    The sample css has nothing in it.
  5. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
    Can't figure out how to get my logo showing.

    Layout.phtml... I deleted

    <h4>Hello From Red Template</h4>
    Here is a sample of theme-based image
    <img src="<?php echo $this->_scriptImg('large-alert.png'); ?>">
    and you can "override" base images.

    In css I put:

    .am-header-content-wrapper {
    height: 92px;
    background: url('../img/gt.jpg') repeat-x top left #FFFFFF;
    }

    .am-header-content {
    padding-top: 1em;
    }

    But it's not taking for some reason.

    I also have a funny //<![CDATA[ issue. See attached txt file. This is when viewing the /amember/signup form.

    Attached Files:

  6. gswaim

    gswaim CGI-Central Partner

    Joined:
    Jul 2, 2003
    Messages:
    641
    John,

    I think you are using aMember with WordPress. In my case when I checked the "Use WordPress Theme" as mentioned earlier in this thread, the aMember pages "automagically" added my WordPress header, footer, and styling. On my site when you go from a WP page to an aMember page, the transition is seamless with zero coding.
  7. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
    Hi Grant. I tried that but the header and footer end up entirely different. I'm using the Catalyst theme and Amember doesn't pull in the correct header and footer stuff.

    The styling is all fckd up.
  8. gswaim

    gswaim CGI-Central Partner

    Joined:
    Jul 2, 2003
    Messages:
    641
    Thats a bummer. You should report this on the BugTracker and let aMember take a look. They need to be aware of this since there will be others that use this theme.
  9. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
    Bug Tracker... is that a forum here?
  10. gswaim

    gswaim CGI-Central Partner

    Joined:
    Jul 2, 2003
    Messages:
    641
    Sorry for not including all the info. Here is the link: http://bt.amember.com/login
    I think it is set up to use the same username / password as your aMember account.

    Here you can submit bugs like you have encountered (click on the New Issue tab) or suggest features. You can also see the progress on releases on the Road Map tab.
  11. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
    Hmmm... that's lists all the issues and goings on. Nowhere to add my issue.

    Not sure if I'm meant to be able to see all that stuff.
  12. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
    Oh yes there is... sorry.
  13. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    John,
    I saw bug request from you, however I can't check this because catalyst is paid theme, and I don't have an access to it.
    Can you contact me at alexander@cgi-central.net and provide access info. I will fix "use wordpress theme" setting to work with catalyst theme and update it on your installation.
  14. jbildy

    jbildy Member

    Joined:
    Aug 22, 2006
    Messages:
    97
  15. chair

    chair New Member

    Joined:
    Dec 27, 2013
    Messages:
    5
    I now have this issue. aMember was integrating with our WordPress theme nicely for over a year until someone pointed out today the "Hello From Red Template" header now visible. I'm sure it is just a strange update to WordPress that doesn't jive with aMember, but I do need to get it fixed. http://keepbastropcountybeautiful.org/kbcbmembers/signup/individual
  16. chair

    chair New Member

    Joined:
    Dec 27, 2013
    Messages:
    5
    Fixed myself. My host had changed the full server path to the aMember install. I had to update and Apply in both the aMember Wordpress plugin and in the aMember Wordpress configuration. Theme is back along with widgets!

Share This Page