Fatal Error after installation

Discussion in 'Troubleshooting' started by balloonmaster, Feb 6, 2016.

  1. balloonmaster

    balloonmaster aMember Pro Customer

    Joined:
    Feb 6, 2016
    Messages:
    4
    I try to install amember on a mac with El Capitan and the newest MAMP PRO Version. After the message that amember is not configured and click on the link I get the following message:

    Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /Applications/MAMP/htdocs/amember/setup/index.php:36 Stack trace: #0 {main} thrown in /Applications/MAMP/htdocs/amember/setup/index.php on line 36

    Did it happen to anyone else? Any ideas?
  2. jenolan

    jenolan aMember Coder

    Joined:
    Nov 3, 2006
    Messages:
    493
    Do you have it set to php v5.6 as the highest?
  3. balloonmaster

    balloonmaster aMember Pro Customer

    Joined:
    Feb 6, 2016
    Messages:
    4
    No, its PHP 7.0. But i read that its works with 7.0. Is this the problem?

    It was, thanks. Now it works
    Last edited: Feb 7, 2016
  4. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,642
    aMember version 3 (according error message I assume you tried to install this version) is very outdated version and it even not compatible with PHP 5.3. I strongly do not recommend to use version 3 for new installation.

    Do you mind to use latest version? aMember 5.0.0 is compatible with PHP 7

    Best Regards.
  5. balloonmaster

    balloonmaster aMember Pro Customer

    Joined:
    Feb 6, 2016
    Messages:
    4
    But the download for the Beta doesnt work, can you help me? I get the message "
    t encoding failed". What does it mean, can you send a link or something?
  6. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,642
    I am sorry for issue. It is fixed now. You should be able to download aMember from your account.

    Best Regards.
  7. balloonmaster

    balloonmaster aMember Pro Customer

    Joined:
    Feb 6, 2016
    Messages:
    4
    Script Error
    An internal error happened in the script, please contact webmaster for details

    After download the Version 5 i switched my MAMP to Version 7. I got the same error as on the beginning. I switched the PHP Version down to 5.5.10 and it worked. So Far so good.
    The installation and everything was fine. On the first click to the admin page i got the error above. What i am doing wrong?
  8. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,642
    What do you have in error log?
    aMember CP -> Utilities -> Logs

    I suggest to submit ticket in our helpdesk
    https://www.amember.com/support

    We will troubleshot this issue.

    Best Regards.

Share This Page