Disgusting Behaviour of Amember Staff

Discussion in 'Testimonials' started by eftnewlife, Sep 3, 2015.

Thread Status:
Not open for further replies.
  1. eftnewlife

    eftnewlife aMember Pro Customer

    Joined:
    Oct 1, 2012
    Messages:
    18
    I need to reinstall the amember version that i bought as the i had to cancel it and, as i said, reinstall it.

    Now i don't need support or a new version. I just want right now to reinstall the version that i bought. This is agreing with Amember policy:
    "Your existing aMember Pro installation will work for lifetime according to license agreement, but to receive upgrades and support, you may purchase subscription renewal."

    So i go to my member area to download the version that i bought but there is not the download link

    I write to the assistance and they tell me that i have to buy the renewal. I told them "I DON'T NEED NEITHER UPGRADES NEITHER SUPPORT RIGHT NOW!, JUST THE VERSION OF AMEMBER THAT I BOUGHT"

    Result? No answer

    I am sick and tired of Amember staff not respecting what they say when they sell the script!!!

    Do what you should do, don't ask every time for money!!!!!!
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Fabrizio,
    Well, we never promised to keep the version which you have bough. So why didn't you keep the script which you have purchased?
    Of course we will send you version that you have purchased, I'd have done this anyway, without your complaint in our forum. I just wasn't able to answer to your ticket in time. Let me know what version did you have installed and I will send files.
  3. eftnewlife

    eftnewlife aMember Pro Customer

    Joined:
    Oct 1, 2012
    Messages:
    18
    It is clear that you told it was compulsory to buy the 12 months support and upgrades

    Anyway... 4.2.16
  4. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    I sent link via helpdesk. Yes we asked you to purchase support and upgrades, I always recommend to use latest version of any software. Version which you requested was developed in 2012 year (3 years ago), there a lot of new functionality and more importantly there are a lot of bug fixes.
Thread Status:
Not open for further replies.

Share This Page