Disabling Cart Plugin Destroyed aMember?

Discussion in 'Troubleshooting' started by stevenjones, Nov 8, 2012.

  1. stevenjones

    stevenjones aMember Pro Customer

    Joined:
    Apr 18, 2012
    Messages:
    42
    Hello!

    I was configuring the amember cart form and decided to disable the cart plugin as I don't need it for my membership site.

    I disabled it via the Setup Global and now the whole script collapsed?

    I got the following message...


    Script Error
    An internal error happened in the script, please contact webmaster for details

    Would love to see this fixed ASAP as I do have some existing members, making use of the software.

    Steven

    P.S. Also opened a ticket...

    P.P.S. Concerns are high as my launch is coming up and I need everything to run properly..
  2. alex

    alex Administrator Staff Member

    Joined:
    Jan 24, 2004
    Messages:
    6,020
    Strange, I guess it was something not related with cart module disabling. No records in logs. Perhaps a database problem on host or something similar.
  3. dmalone

    dmalone New Member

    Joined:
    Nov 12, 2012
    Messages:
    1
    I too have this problem, has there been any suggested solutions? I've deleted and recreated all Products but still no change, cant get new members signed up and no new members can signup..
    Its a new installation and not live yet so I could do a full reinstall, any links to reinstall instructions?

    Logged a ticket too.

    Thanks
    Steven
  4. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Close all browser windows and then restart browser, error will gone away.
    aMember store some objects related to shopping cart in php session, so when you disable cart module, aMember is unable to find classes for these object so it throws an exception. This must be fixed in core through
  5. tiginc

    tiginc aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    2
    It would help a lot if some of the solutions were actually posted in the forum. Just a thought.
  6. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,689
    @tiginc alexander already posted solution - close your browser and open again. There was issue with object in session but it was fixed long time ago. You should not face this issue in latest version at all.

Share This Page