Disable 'Require Unique Email'?

Discussion in 'Troubleshooting' started by rripps, Jan 16, 2012.

  1. rripps

    rripps New Member

    Joined:
    Jun 12, 2009
    Messages:
    6
    aMember v3.2.4PRO

    I turned 'Require Unique Email' on initially, then turned it off to be able to test a new configuration with different users w/ the same email address across several subscription products. This message still comes up when I try to log in:
    "ERROR: Duplicate email address! Cannot create new user. Please log out then contact site admin."

    Q1: If 'Require Unique Email' is not checked, why would I continue to get this message?
    Q2: How do I 'clear' a particular users account after deleting the other accounts that have the same email address? (would like to avoid a user having to re-subscribe)

    Thank you,
    Roger
  2. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Roger,
    it seems that error is generated by integration plugin you have installed and not by aMember itself.
    What plugins you have enabled in amember CP?
    Also, sorry didn't understand your last question.
  3. rripps

    rripps New Member

    Joined:
    Jun 12, 2009
    Messages:
    6
    Alexander,

    I have only these:
    Payment plugins -
    1shoppingcart
    Free
    Protect Plugins -
    htpasswd
    new_rewrite
    php_include

    For my second question, please disregard; the circumstances will change if Q1 is clarified.
    Thanks!
  4. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Well I tryed to search for such error message, and there is no such error message in aMember at all.
    So, this is a result of customization. Contact me in helpdesk I will check what can be done.
  5. rripps

    rripps New Member

    Joined:
    Jun 12, 2009
    Messages:
    6
    Well, I've discovered wordpress users that were not in the amember db. So wordpress was putting that error message up.

    Thanks for looking into that! Sometimes getting the 'all-clear' helps redirect attention to the real issues.
    Resolved.

Share This Page