CSRF protection Error

Discussion in 'Troubleshooting' started by lijogeorge, Aug 29, 2013.

  1. lijogeorge

    lijogeorge New Member

    Joined:
    Aug 27, 2013
    Messages:
    1
    I asked the Support, its been nearly under 48 hrs... no response... very sad ):

    Question:
    When i go to my Form Editor, and edit and then click Submit, it gives me this error:

    CSRF protection error - form must be submitted within 60 minutes after displaying, please repeat

    Please help as i cant do anything without editing forms


    Problem:
    Form editor > edit any form > click save or submit
    the form returns with a Error


    I have uploaded the screenshot

    Attached Files:

  2. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,669
    As I see this issue is already closed in helpdesk. The issue is you have many additional fields and each field brick has its own configuration form. Buffer with CSRF codes was overloaded. We implemented fix for such situation. It will be included in next release.
  3. frtyu

    frtyu New Member

    Joined:
    Dec 17, 2008
    Messages:
    21
    I got the same problem. Does it mean its going to be fixed until the next release? What do i do in the mean time? The script is useless without this feature working properly.
  4. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,669
    This fix is included in latest version. Please contact us in helpdesk we will help you with it.
  5. frtyu

    frtyu New Member

    Joined:
    Dec 17, 2008
    Messages:
    21
    Hi,

    i just upgraded to latest version the other day. Have you just released a new one? Which one is it?

    Thank you.
  6. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,669
    Latest version is 4.3.5. In case you still have this issue please contact us in helpdesk and we will check what can be wrong.
  7. nerdfrog

    nerdfrog New Member

    Joined:
    Oct 31, 2014
    Messages:
    1
    I'm running 4.4.4 and have this problem. I cannot log into the admin or as a member! I hope that there is a fix for this because amember is completely NOT usable.
  8. chrome62

    chrome62 Member

    Joined:
    Apr 22, 2008
    Messages:
    89
    I'm also getting this error in my income reporting.
    CSRF protection error - form must be submitted within 60 minutes after displaying, please repeat

    This forum is useless...nobody from aMember ever posts solutions, just the same old "send us your login credentials and we'll fix it"...some of us are capable of following directions.

    BTW guys - not many people are comfortable giving you their FTP, cpanel and aMember logins.
  9. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,669
    All common issue is fixed in releases. It is either not possible or very difficult to troubleshoot installation specific issue without access. Anyway I recommend you to contact us in helpdesk (https://www.amember.com/support) we will find some solution for you.
  10. jwhysleep

    jwhysleep aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    4
    I thought this was fixed
  11. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    What aMember version do you have installed ?
  12. jwhysleep

    jwhysleep aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    4
    * aMember Pro Config File
    *
    * Author: Alex Scott
    * Email: alex@cgi-central.net
    * Web: http://www.amember.com/
    * FileName $RCSfile$
    * Release: 4.3.6 ($Revision$)
    Last edited: Apr 10, 2015
  13. jwhysleep

    jwhysleep aMember Pro Customer

    Joined:
    Aug 22, 2006
    Messages:
    4
    After the Update still no access... interesting
  14. thehpmc

    thehpmc Member

    Joined:
    Aug 24, 2006
    Messages:
    901
    But what version of aMember?

    I have version 4.5.1 on development site but the config file says 4.3.1. That is the version of that file not aMember.
  15. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Yes that is version of config file.
    You can find amember version at the bottom of any aMember CP page, or in amember CP -> Version Info.
  16. ccwjames

    ccwjames Member

    Joined:
    Sep 11, 2014
    Messages:
    430
    CSRF error here cant login on new 4.6.3 install
  17. ccwjames

    ccwjames Member

    Joined:
    Sep 11, 2014
    Messages:
    430
    support dont seem to reply quick do that?

    very upsetting to a new sub again of the software, cant get in my admin and no help after 12 hours and ticket desk been open 2 hours. no one in usa to reply to help desk?
  18. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    Unfortunately we don't have someone in USA so that's why there are delays. Is that field now? If you still get such issues, provide ticket number I will check this asap.
  19. ccwjames

    ccwjames Member

    Joined:
    Sep 11, 2014
    Messages:
    430
    was sorted out was a lenience php problem.
  20. websiteworldbiz

    websiteworldbiz New Member

    Joined:
    Aug 7, 2013
    Messages:
    10
    I am getting the same issue.

Share This Page