Cloudflare Incompatible With aMember?

Discussion in 'Troubleshooting' started by brap, Jun 3, 2016.

Thread Status:
Not open for further replies.
  1. brap

    brap New Member

    Joined:
    May 5, 2014
    Messages:
    5
    I have a membership site set up with aMember as an "internal" Wordpress blog. In other words, I have a root level blog to deal with with general issues and sales, etc etc. And then I have a folder /member, and in that folder I put my Wordpress blog with aMember. I have had this membership site for two years already, and it has worked seemingly seemlessly. The membership site is a course where they view videos (mp4/flash produced with Camtasia) online, or to download them.

    Towards the end of 2015 I noticed that I was being mercilessly attacked with all kinds of spam traffic and the like on all of my domains. It disturbed me very much for a few reasons.

    I set up an account with Cloudflare, and if it is relevant I will admit that I set it up with the product Traffic Shield.

    Anyway, I noticed recently that the videos were not playing on the site. In other words, the new tab came up, but the iframe didn't load, the gif just spun and spun and spun.

    In the outside bog, the root level blog, the videos were playing fine.

    I troubleshooted many things that came to mind. I couldn't find the problem. I thought of Cloudflare, and when I changed the dns settings back to my hosting's instead of what Cloudflare gave me, then lo and behold 24 hours later everything worked fine.

    I understand that there is some kind of incompatibility with aMember.

    Does anyone have experience with this issue that can guide me what to do?

    Thank you very much.
  2. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,686
    In most cases cause of this issue is Rocket Loader. Do you mind to disable Rocket Loader in your Cloud Flare account and check how it goes.
    brap likes this.
  3. brap

    brap New Member

    Joined:
    May 5, 2014
    Messages:
    5
    Thank you very much. I will try this and report tomorrow, because in order to test I will need to put the Cloudflare dns settings back again.
  4. brap

    brap New Member

    Joined:
    May 5, 2014
    Messages:
    5
    OK, I tried this solution, I disabled Rocket Loader in my Cloud Flare account, and sure enough it worked. Thank you very very much.
  5. caesar

    caesar aMember Pro Developer Staff Member

    Joined:
    Oct 16, 2009
    Messages:
    1,686
    I glad to hear everything works properly now. You are welcome!
Thread Status:
Not open for further replies.

Share This Page