Can't upgrade from old version! Affiliate links not working

Discussion in 'Troubleshooting' started by taurenmill, Jul 29, 2016.

  1. taurenmill

    taurenmill New Member

    Joined:
    May 2, 2009
    Messages:
    16
    Hello,

    I am using version 4.2.15 of amember currently. Everything was fine until today when I noticed affiliates banners and links are now redirecting to an amember page with the site URL at the end. Example:

    http://www.mysite.com/amember/aff/www.mysite.com

    it redirects to this and gives them a 404 error. I have changed nothing with the affiliate program.

    To attempt fixing this, I decided to pay the $80 to upgrade to current version, but when I try to upgrade through amember it just gives me the error:
    Script Error
    An internal error happened in the script, please contact webmaster for details

    I am trying to launch my product very soon and have sent out hundreds of emails to potential affiliates and all my affiliates are currently upset due to being sent to a 404 page.

    Someone please help me with this!
  2. jenolan

    jenolan aMember Coder

    Joined:
    Nov 3, 2006
    Messages:
    493
    As it is the weekend, I would suggest raising an urgent ticket ask for the crew to fix.

    Or you could try the checker I have written over at JLogica for a quick sanity test.
  3. taurenmill

    taurenmill New Member

    Joined:
    May 2, 2009
    Messages:
    16
    I attempted installing the amember upgrade directly in host and now there are all kinds of problems... The update seemed to have worked but now there are lists of links instead of a header with links in the members profile and admin.

    Also getting other strange errors now.
  4. jenolan

    jenolan aMember Coder

    Joined:
    Nov 3, 2006
    Messages:
    493
    If you raise the urgent ticket someone from the CGI crew will look at it and fix.

    If you want me to look at it you would need to go over to JLogica, register and add a ticket but I there would be a cost as I am not official support.
  5. taurenmill

    taurenmill New Member

    Joined:
    May 2, 2009
    Messages:
    16
    Thanks ienolan,

    I have contacted with urgent ticket. If things don't get moving quickly enough I will be signing up to have you help.

    I had my default amember theme edited a while back and I believe this is the issue. Or Files didn't overwrite correctly. Here is images of the links it is displaying instead. I also noticed the sign up form headers changed.

    Attached Files:

  6. jenolan

    jenolan aMember Coder

    Joined:
    Nov 3, 2006
    Messages:
    493
    Yah problem with most people doing customisations is that they do not know how to make them safe to upgrade, it takes a lot more work. Theme stuff if more than the site.css needs to be a custom theme etc ;-)

    Best of luck, gimme a yell and I will try and help.

Share This Page