Can't login (admin + frontend)

Discussion in 'Troubleshooting' started by herm1ne, May 8, 2014.

  1. herm1ne

    herm1ne New Member

    Joined:
    May 4, 2014
    Messages:
    5
    Hi
    My aMember is v4.3.6
    I CAN login from my main laptop which usually used to log in, however, today, I noticed that I could NOT login from either my secondary laptop or my iPhone.
    When I type correct ID/PW, it happens nothing. Just like refresh login page, no error, nothing changed. (In admin log, it says "logged in" even though I cant login)
    When I type wrong ID/PW, error massage appears, as usual.

    I googled and I checked that there is .htaccess file in my root directly.
    My aMember Root URL is http://subdomain.mydomain.com/
    My server directly is /home/<my ID>/public_html/<subdomain>
    so I think the following .htaccess is correct
    Code:
    #  Sample Nginx rules configuration:
    #  aMember rules (replace /amember to actual aMember Pro path from site root)
    #
    #      location ~* ^/amember/.*\.(js|ico|gif|jpg|png|css|swf|csv)$ {}
    #      location ~* ^/amember/setup/index.php$ { try_files not-existing-file @php; }
    #      location ~* ^/amember/js.php { try_files not-exiting-file @php; }
    #      location ~* ^/amember/index.php$ { try_files not-existing-file @php; }
    #      location ~* ^/amember/public.php$ { try_files not-existing-file @php; }
    #
    #      location ~* ^/amember/public { rewrite ^.*$ /amember/public.php; }
    #      location ~* ^/amember/setup { rewrite ^.*$ /amember/setup/index.php; }
    #      location ~* ^/amember { rewrite ^.*$ /amember/index.php; }
    #
    #  you must already have something like that in your nginx configuration:
    #
    #      location ~ \.php$ {
    #          try_files not-existing-file @php;
    #      }
    #      location @php {
    #        fastcgi_pass 127.0.0.1:9000;
    #        include fastcgi_params;
    #      }
    #
    #  it is necessary to have @php section, as it is referred by aMember rules, and
    #  it must be located at bottom
    #
    #
    <IfModule mod_rewrite.c>
        RewriteEngine on
    # You may need to uncomment the following line if rewrite fails to work
    # RewriteBase must be setup to base URL of your aMember installation without
    # domain name
        RewriteBase /
        RewriteRule ^public public.php [L]
        RewriteRule ^js.php js.php [L]
        RewriteRule !\.(js|ico|gif|jpg|png|css|swf|csv|html)$ index.php
    </IfModule>
     
    <IfModule mod_php5.c>
    #  php_flag magic_quotes_gpc off
    </IfModule>
    
    I am sure that my laptop and phone is Javascript and Cookie enabled.
    My protection plugin is only new_rewrite and Single Session Login is enabled.

    My browser is Google Chrome v34 (main/secondary/mobile)
    I also tried Internet Explorer but still I can't login

    Any ways to solve this issue?
  2. herm1ne

    herm1ne New Member

    Joined:
    May 4, 2014
    Messages:
    5
    Here is additional info.
    .htaccess re-uploaded -> doesnt work (I tried both uncommented and commented on Line RewriteBase)
    Log in from my main laptop(which I can still loggin) and make new admin account and try to login from secondary laptop -> cant login

    Thanks
  3. herm1ne

    herm1ne New Member

    Joined:
    May 4, 2014
    Messages:
    5
    Problem Solved.
    .htaccess doesnt load properly due to character set
    /closed
  4. landshark

    landshark New Member

    Joined:
    Feb 6, 2013
    Messages:
    8
    Could you explain how you fixed it further?

    I'm having a similar problem. Enter login and pass press the "login" button and nothing happens. Refresh the page and I'm logged in. I'm lost.
  5. alexander

    alexander Administrator Staff Member

    Joined:
    Jan 8, 2003
    Messages:
    6,274
    aMember submits login form via ajax request. And this request failed for some reason.
    What is url of your login page?
  6. landshark

    landshark New Member

    Joined:
    Feb 6, 2013
    Messages:
    8
    I submitted a support ticket yesterday as well.

Share This Page