Cannot login as admin unless first logged in WP admin

Discussion in 'Setting-up protection' started by probillpro1, May 18, 2014.

  1. probillpro1

    probillpro1 New Member

    Joined:
    Feb 26, 2012
    Messages:
    2
    I've recently changed host and had to move my aMember folder under http://example.org/wp-content/amember - whereas before it as in http://example.org/amember. Since then I cannot login as an admin to amember unless I am first logged into the WP panel. Regular amember users do not experience that issue.

    Anyone have an idea what is going on?
  2. thehpmc

    thehpmc aMember Pro Customer

    Joined:
    Aug 24, 2006
    Messages:
    901
    Simple terms it would seem Wordpress is protecting your aMember installation and you need to pass its protection to reach aMember.

    Why have you changed the structure to the way you have? aMember should be in its own directory.
  3. probillpro1

    probillpro1 New Member

    Joined:
    Feb 26, 2012
    Messages:
    2
    I figured WP was doing something but not sure what - it's not stopping regular amember user logins which has a similar path. Just admins - also when I try to log in as admin it doesn't throw any error messages - just reloads the login page with no errors - I think it's logging me in because if I do that, then login to WP then come back to the amembe admin and reload I am logged in.

    As far as why - I am on WPEngine which doesn't allow anything outside of wp-content folder

Share This Page