Amember users are not imported in Vbulletin

Discussion in 'Integration' started by cusinndzl, Jul 20, 2013.

  1. cusinndzl

    cusinndzl Guest


    I had v4.2.17 and this feature worked great. When a new member was registered in amember, he could login successfully also in the forum.
    I have moved the forum and amember to a another host (VPS) and after that I have upgraded to latest version 4.2.19. Next day I have noticed that new users couldn't login to forum. Checked the users list in vbulletin and notices that new registered users in amember are not imported any more in vb.

    I have done all troubleshooting steps: disable/enable plugin. The configurations works without issue. I have run rebuild vb database. I don't get any error, but still doesn't work.
  2. cusinndzl

    cusinndzl Guest

    More info: by using the vbulletin plugin version 4.2.19 and 4.2.17 I get this error when trying to configure the plugin:
    An Error has occured
    The database has encountered a problem, please try again later.
    And in amember logs:
    No database selected at /home/xxxxxx/public_html/account/library/Am/Protect/Databased.php line 705(1046) in query: SELECT usergroupid as id, title as title, (usergroupid=8) as is_banned, (usergroupid IN (5,6,7)) as is_admin FROM usergroup

    Exception Am_Exception_PluginDb
    call_user_func [ library/DbSimple/Generic.php : 1244 ]
    DbSimple_Generic_LastError->_setLastError [ library/DbSimple/Generic.php : 861 ]
    DbSimple_Generic_Database->_setLastError [ library/DbSimple/Generic.php : 1481 ]
    DbSimple_Mypdo->_setDbError [ library/DbSimple/Generic.php : 1441 ]
    DbSimple_Mypdo->_performQuery [ library/DbSimple/Generic.php : 465 ]
    DbSimple_Generic_Database->_query [ library/DbSimple/Generic.php : 134 ]
    DbSimple_Generic_Database->select [ library/Am/Protect/Databased.php : 705 ]
    Am_Protect_Databased->getAvailableUserGroups [ library/Am/Form/Setup/ProtectDatabased.php : 78 ]
    Am_Form_Setup_ProtectDatabased->initElements [ library/Am/Form/Setup.php : 70 ]
    Am_Form_Setup->prepare [ application/default/controllers/AdminSetupController.php : 67 ]
    AdminSetupController->displayAction [ library/Am/Controller.php : 139 ]
    Am_Controller->_runAction [ library/Am/Controller.php : 116 ]
    Am_Controller->dispatch [ library/Zend/Controller/Dispatcher/Standard.php : 295 ]
    Zend_Controller_Dispatcher_Standard->dispatch [ library/Zend/Controller/Front.php : 954 ]
    Zend_Controller_Front->dispatch [ library/Am/App.php : 1675 ]
    Am_App->run [ index.php : 43 ]

    By using the original plugin version 4.2.7, I don't get that error. But still, new users are not imported in vb.
    Tried to edit a username in amember, and the that renamed username was updated into vb (repeated this step a few times and worked every time. So, it seems the old version updates existing usernames, but doesn't add new usernames. I have 9 users in vb.
  3. cusinndzl

    cusinndzl Guest

    UPDATE: managed to use latest vb plugin. I don't get any errors now, but still doesn't work.
    I have deleted the forum and database. Made a clean install, and tested again. Only 5 users were imported from amember to vb. Now, I'm sure that is a amember/plugin bug.
  4. cusinndzl

    cusinndzl Guest

    Finally solved. After countless tries: moved back to old host, different amember versions, different vbulletin plugin versions, deleted forum and db and resintaled, till a fresh amember DB and here I have figured out why it wasn't working. After that I have reimported my old amember DB and fixed the issue.

    What issue was? It seems that the records on aMember CP -> Protect Content -> Integrations page were somehow damaged!?! I have deleted all (4) and then I have recreated them back. And surprise! My issue was solved.

    The ticket can be closed.

    Thank you for support.

Share This Page